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1. Host Computer Requirements
Before installation of the LPCXpresso IDE, you should make sure your development host
computer meets the following requirements:

• A standard x86 PC with 2GB RAM minimum (4GB+ recommended) and 1GB of available
disk space, running one of the following operating systems:

• Microsoft® Windows Vista

• Microsoft® Windows 7

• Microsoft® Windows 8.1

• Microsoft® Windows 10

• Linux – Ubuntu 12 and later

• Linux – Fedora 18 and later

• An x86 Apple Macintosh with 2GB RAM minimum (4GB+ recommended) and 1GB of
available disk space, running one of the following Mac OS X versions:

• 10.8.5 (or later) / 10.9.4 (or later) / 10.10 (or later)

Additional host platform notes:

• Starting with LPCXpresso v7.1, and following the discontinuation of support by Microsoft,
Windows XP is no longer an officially supported platform. LPCXpresso may continue to
work on Windows XP but this can no longer be guaranteed. LPCXpresso is no longer
tested on Windows XP.

• Starting with LPCXpresso v7.4, Mac OS X 10.7 (Lion) is no longer an officially supported
platform. LPCXpresso may continue to work on Mac OS X 10.7 but this can no longer
be guaranteed. LPCXpresso is no longer tested on Mac OS X 10.7.

• Both 32-bit and 64-bit Windows / Linux systems are supported.

• The LPCXpresso IDE may install and run on other Linux distributions. However, only the
distributions listed above have been tested. We have no plans to officially support other
distributions at this time.

• A screen resolution of 1024x768 minimum is recommended.

• An internet connection is required to request, install, and activate license keys. When
using the product, an internet connection is required to update the product and to
download new examples.
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2. Installation
When installing, all components of the LPCXpresso IDE are installed, but some functionality
may be restricted by the currently installed license activation.

2.1  Windows

The LPCXpresso IDE is installed into a single directory, of your choice. Unlike many
software packages, the LPCXpresso IDE does not install or use any keys in the Windows
Registry, or use or modify any environment variables (including PATH), resulting in a very
clean installation that does not interfere with anything else on your PC.

Should you wish to use the command-line tools, a command file is provided to set up the
path for the local command window.

2.2  Mac OS X

The LPCXpresso IDE installer is supplied as a Mac OS X .pkg installer file. Double click on
the installer to install the LPCXpresso IDE into a subfolder of your Applications folder.

To start the LPCXpresso IDE, use the Mac OS X Launchpad. Alternatively click the Open
lpcxpresso icon in the /Applications/lpcxpresso_version folder or run lpcxpresso.app,
which can be found in the lpcxpresso subfolder of the main LPCXpresso IDE installation
directory within /Applications.

2.3  Linux

Due to the huge variation in capabilities of different Linux distributions, LPCXpresso is only
tested and supported on recent versions of Ubuntu and Fedora. The LPCXpresso IDE may
work on other distributions but we cannot provide support if it does not work.

The installer is supplied as an executable that installs the LPCXpresso IDE components.
The installer requires root privileges, although, once it is installed, no special privileges are
required to run the LPCXpresso IDE. The installer will request a super-user password when
it is started. Once installation has completed, we strongly recommend that your system is
restarted — if you do not do this then some areas of the tools may not function correctly.
The installer should be started from the command line, but will switch to GUI mode once
the super-user password has been entered.

2.3.1  Installation on 32-bit distributions

The LPCXpresso IDE is a 32-bit product that should run on most 32-bit Linux distributions.
On some distributions some additional packages may be required for USB compatibility
(see below for the latest information). Note that GLIBC v2.15 or greater is required.

  Enabling the LPCXpresso IDE internal Web Browser

On most recent Linux distributions, an additional package must be installed to enable the
IDE’s internal Web Browser. If this is not installed, any web pages displayed by the IDE will
be displayed in the system default Web Browser.

  Ubuntu

Run the following command to install the webkit package that enables the internal Web
Browser:
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 sudo apt-get install libwebkitgtk-1.0-0

  Fedora

Run the following command to install the webkit package that enables the internal Web
Browser:

 sudo yum install webkitgtk.i686

2.3.2  Installation on 64-bit distributions

The LPCXpresso IDE is a 32-bit product. For 64-bit versions of Linux, the 32-bit
compatibility components must be installed. Note that all of these components must be
installed, otherwise the installation program will not run and the LPCXpresso IDE will
not function correctly. To install these components from the command line, follow the
instructions below for your distribution.

  Ubuntu 13.10 or later:

Ubuntu 13.10 no longer provides a convenient method to install all 32-bit compatible
libraries, so they must all be installed individually. Those that are required for LPCXpresso
7 are as follows:

 sudo apt-get install libgtk2.0-0:i386 libxtst6:i386 libpangox-1.0-0:i386 \ 

      libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386 \

      libncurses5:i386 libudev1:i386 libusb-1.0:i386 libusb-0.1:i386 \

      gtk2-engines-murrine:i386 libnss3-1d:i386 libwebkitgtk-1.0-0

  Ubuntu 13.04 or earlier:

Ubuntu 13.04 and earlier provides a convenient method to install 32-bit compatible libraries.
These can be installed using the follow command:

 sudo apt-get install linux32 ia32-libs 

  Fedora

Install the following 32-bit libraries:

 sudo yum install gtk2.i686 glibc.i686 glibc-devel.i686 libstdc++.i686 \

  zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 \

  libXrandr.i686 libusb.i686 libXtst.i686 nss.i686 libcanberra-gtk2.i686 \

  PackageKit-gtk3-module.i686 webkitgtk.i686

  Other Linux Distros

While not officially supported, the LPCXpresso IDE has been reported to work on many
other Linux Distros, including Linux Mint, openSUSE and Debian. When attempting to run
on these Distros, remember that LPCXpresso is a 32-bit application and so various 32-bit
compatible libraries must be installed. These include:

 libgtk2.0-0:i386 libxtst6:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 \

 libidn11:i386 libglu1-mesa:i386 libncurses5:i386 libudev1:i386 \

 libusb-1.0:i386 libusb-0.1:i386 gtk2-engines-murrine:i386 \
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 libnss3:i386

Also note that that the glibc 2.15 shared library is required.

We are unable to provide assistance when installing on other Distros, but the LPCXpresso
forum on http://www.lpcware.com is a good place to search for information or post
questions.

2.3.3  Post-installation issues

  dfu-util fails to run

On some Linux systems, when booting LPC-Link or LPC-Link2, the supplied version of dfu-
util may fail to execute. To resolve this you may need to install an additional component:

  sudo apt-get install libusb-0.1-4:i386 # Ubuntu

This should only be installed on systems where dfu-util fails to run.

  Connection Refused error

When starting a debug session, on some Linux systems, a "Connection refused" error
may be displayed. This happens because a critical system library is not installed where
we expect to find it.

To resolve this issue, open a Terminal Window and execute the following commands (if
running a 64-bit version of Linux, you must first install the 32-bit compatibility libraries as
described above):

Note: The actual location of this library may depend on the distribution and version of Linux
you are running.

  Ubuntu

 cd /lib/i386-linux-gnu

 sudo ln -sf libudev.so.1 libudev.so.0

  Fedora

 cd /usr/lib/

 sudo ln -sf libudev.so.1 libudev.so.0

  Ubuntu-specific issues

When using the Unity interface, there may be an issue preventing some menu items
from displaying in the LPCXpresso IDE (this does not affect the ‘Classic’ interface). To
workaround this problem, create a shell script with the following content, and start the
LPCXpresso IDE by running this script:

 #!/bin/bash

 export UBUNTU_MENUPROXY=0

 /usr/local/<lpcxpresso_install_dir>/lpcxpresso/lpcxpresso

  Fedora-specific issues

If SELINUX is used, it must be set to “permissive” mode to allow the LPCXpresso IDE to run.
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2.4  Running under Virtual Machines

It is possible to install the LPCXpresso IDE within a virtual machine (VM) environment.
Generally such installations cause few issues, however due to the nature of VMs the most
likely problems relate to sharing of resources (USB, memory).

In the unlikely event that you experience issues, we welcome reports but due to the nature
of VM operation we can offer no guarantee of resolution.
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3. Activation
An LPCXpresso IDE installation will take one of the following three forms:

• Unregistered : the initial product state following a new customer installation, features
are restricted, and code size is limited to 8KB

• Free Edition : following installation of a Free Edition Activation code, maximum debug
download size is limited to 256KB, some advanced debug features are restricted.

• Pro Edition : following installation of Purchased Pro Edition Activation code, no
restrictions apply

Note
If you have previously activated LPCXpresso IDE v6.x or v7.x, then your
existing activation code is compatible with LPCXpresso IDE v8.x. There is
no need to reactivate. To identify the current instalation type use: Help ->
Display License Type. For more information please see Appendix B – License
Compatibility with Older Products

3.1  Unregistered (UNREGISTERED) license

Initially after installation LPCXpresso IDE will run with a default Unregistered
(UNREGISTERED) license. Most features of the product may be used, although some
functionality is restricted, including the size of applications that you can build and debug
(limited to 8Kbytes), and Trace functionality is disabled. Activate your product with a Free
Edition or Pro Edition license to remove these restrictions.

3.2  Activating your product (LPCXpresso Free Edition)

A Free Edition activation code may be obtained, free of charge, by registering the
LPCXpresso IDE. This provides a license to use the complete development environment
with a 256KB debug download size limit.

Note
Before you can activate LPCXpresso IDE you will first need to have created
an account on the LPCWare website and be logged in.

To activate your installation with a Free Edition license, from within LPCXpresso IDE:

1. Go to the menu entry Help->Activate->Create Serial number and register (Free
Edition)...

• Your product’s serial number will be displayed

• Write down the serial number, or copy it into the clipboard.

2. Press OK and a web browser will be opened on the Activations page

• If you are already logged in to the website, the serial number will be entered for you.

• If you are not logged in, you will need to login, navigate to http://www.lpcware.com/
lpcxpresso/activate, and enter the product’s serial number.

3. Press the button to Register LPCXpresso

• Your LPCXpresso Activation code will be generated and displayed.

4. Go to the menu entry Help->Activate->Activate (Free Edition)...

http://www.lpcware.com/
http://www.lpcware.com/lpcxpresso/activate
http://www.lpcware.com/lpcxpresso/activate
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5. Enter your activation code and Press OK.

• This activates your product. The license type will be displayed and you will be able to
use all the features of LPCXpresso, with a debug download limit of 256KB.

Note: An email will also be sent to you containing your Product Serial Number and
Activation Code.

3.3  Activating your product (LPCXpresso Pro Edition)

A full, unrestricted activation code for the LPCXpresso IDE can be purchased via the menu
entry Help->Activate->Purchase from LPCXpresso webstore. Once purchased, your
activation code will be emailed to you.

When the activation code is received, follow the instructions below to activate your product.
From within the LPCXpresso IDE:

1. Go to the menu entry Help->Activate->Activate (Pro Edition)...

2. Enter the Pro Edition activation code provided, and press OK

3. Enter your email address and provide a password of your choosing, and press OK.

Your product will now be activated. The license type will be displayed and you will be able
to use all the features of LPCXpresso with no code size limits.

NOTES

1. The password should be kept safe, as it will be required should you wish reactivate your
license (for example to move your license for LPCXpresso Pro Edition from one PC to
another). Your email address will be used to send a reminder should you forget your
password. We may also send occasional emails from which you may unsubscribe.

2. The first use of an activation code will also trigger an email from Softworkz (our licensing
system partners) to the supplied email address. This email is important because it offers
the option to create an account to centrally manage multiple seats of LPCXpresso. See
http://www.lpcware.com/content/faq/lpcxpresso/initial-activation-email

3.3.1  Multi-Seat Activations

When you purchase LPCXpresso IDE Pro Edition, you can choose to purchase a single
or multi seat license. If you purchase a multi seat license, then you will be provided with a
single activation code that can be used to activate LPCXpresso IDE Pro Edition on multiple
machines.

The major benefit of a multi seat activation code over multiple single seat codes is that this
enables a single activation code to be made available to users whilst offering the ability to
monitor and administer usage centrally.

Single seat licenses can be upgraded to multi-seat licenses by purchasing additional seats.

For additional information please visit:

http://www.lpcware.com/content/faq/lpcxpresso/central-administration-activation-codes

3.4  Further information

Further information on LPCXpresso IDE installation and activation can be found in the FAQ
below:

http://www.lpcware.com/content/faq/lpcxpresso/initial-activation-email
http://www.lpcware.com/content/faq/lpcxpresso/central-administration-activation-codes
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http://www.lpcware.com/faq/activation-licensing

http://www.lpcware.com/faq/activation-licensing
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4. Appendix A – Migration Hints and Tips

4.1  Introduction

Generally, migrating from one version of the LPCXpresso IDE to a later version should
be straightforward, though you should always browse the release notes, the supplied
documentation and online FAQ material.

Below are a number of hints and suggestions of things that you should do or consider when
migrating to a new version of the LPCXpresso IDE.

4.1.1  Parallel Installations

A new version of the LPCXpresso IDE may be installed in parallel with existing installations.
This allows a newly released version to be trialed alongside a version currently installed.

Furthermore, there is no need to take any special care with licenses (activation codes),
since any installed code will automatically be picked by the new LPCXpresso IDE
installation.

4.1.2  Installing Eclipse plugins

If you install a new version of LPCXpresso IDE on Mac OS X or Linux, then the first time you
run the new install you will be offered the opportunity to re-install previously used plugins
(for example, version control). However this does not happen on Windows and manually
installing your favorite plugins may take considerable time to complete.

An alternative approach is to import the plugins from an earlier LPCXpresso IDE installation.
To do this follow:

File->Import->Install->From Existing Installation

Then browse to an existing installation’s internal lpcxpresso directory (i.e. the directory
found within an existing LPCXpresso IDE application’s installation).

4.1.3  Managing Workspaces

Whilst a new LPCXpresso IDE version can open workspaces created by an earlier release,
a workspace (and the projects it contains) that have been used by a new LPCXpresso IDE
version may not correctly load into an earlier version. Thus we would strongly recommend
that you backup your projects before commencing any migration (just in case).

The simplest way to do this is to create a new workspace in the new LPCXpresso IDE
version, then import any projects into this new workspace. How to import projects into a
new workspace is detailed in the FAQ:

https://www.lpcware.com/content/faq/lpcxpresso/how-importexport-projects

Alternatively, if you have your projects checked into a version control system (for example
using SVN and the Subclipe Eclipse plugin), then you can simply check you projects out
into the new workspace.

You should also ensure that you do a full, clean build after switching to the new version.

4.1.4  Launch Configurations

Sometimes the contents of or options specified in the debug launch configurations used by
LPCXpresso IDE can change between versions. Thus when moving to a new version of the

https://www.lpcware.com/content/faq/lpcxpresso/how-importexport-projects
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LPCXpresso IDE, we would recommend deleting any debug launch configurations within
your project which were created by an earlier version. These files are typically named:

<projectname> Debug.launch and <projectname> Release.launch.

The easiest way to do this is to right click on the project in Project Explorer and select:

Launch Configurations -> Delete Launch Configurations

The IDE will then automatically create a fresh set of launch configurations the next time
that you start a debug session. Note that you may need to reapply any modifications you
made to your launch configurations in your previous version of LPCXpresso IDE.

For more information on launch configurations, please see the FAQ Launch Configuration
Menu.

https://www.lpcware.com/content/faq/lpcxpresso/launch-configuration-menu

4.1.5  Startup code

The startup code generated by LPCXpresso IDE can sometimes be updated between
releases, often to support new tool features. We would thus strongly recommend that you
consider updating your startup code to match the latest generated by the project wizard
for the part that you are using.

4.1.6  Linker Scripting

In LPCXpresso IDE V7.9.0 and later, the linker script template mechanism has been
overhauled to provide a much more flexible and powerful means for the user to change the
content of the linker script generated by the managed linker script mechanism.

If you are moving a project that uses a modified linker script from a version of LPCXpresso
IDE prior to version 7.9.0, then please read the detailed FAQ on Freemarker Linker Script
Templates:

https://www.lpcware.com/content/faq/lpcxpresso/freemarker-linker-script-templates

https://www.lpcware.com/content/faq/lpcxpresso/launch-configuration-menu
https://www.lpcware.com/content/faq/lpcxpresso/freemarker-linker-script-templates
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5. Appendix B – License Compatibility with Older
Products

5.1  Users of earlier versions of LPCXpresso IDE

If you have previously been using LPCXpresso IDE v5.x or earlier, then note that your
previous activation code is not compatible with this version. You will need to go through
the activation process again in order to use this version.

5.2  Users of Code Red Technologies Red Suite products

Red Suite activation codes are not compatible with LPCXpresso IDE. You will need to
obtain an LPCXpresso IDE Free or Pro Edition activation code in order to use LPCXpresso
IDE.
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